]> 4ch.mooo.com Git - 16.git/blob - 16/adplug/adplug/adplug.spec
compy4 sync
[16.git] / 16 / adplug / adplug / adplug.spec
1 %define name adplug
2 %define version 2.2.1
3 %define release 1
4
5 Summary: AdLib sound player library
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Source0: %{name}-%{version}.tar.bz2
10 URL: http://adplug.sourceforge.net/
11 License: LGPL
12 Group: Applications/Multimedia
13 BuildRoot: %{_tmppath}/%{name}-buildroot
14 Prefix: %{_prefix}
15 BuildRequires: binio-devel >= 1.4
16 Requires: binio >= 1.4
17
18 %description
19 AdPlug is a free, multi-platform, hardware independent AdLib sound player
20 library, mainly written in C++. AdPlug plays sound data, originally created
21 for the AdLib (OPL2) audio board, on top of an OPL2 emulator or by using the
22 real hardware. No OPL2 chip is required for playback.
23
24 It supports various audio formats from MS-DOS AdLib trackers.
25
26 %package devel
27 Group: Development/Libraries
28 Summary: Development files of AdPlug
29 Requires: %name = %version-%release
30 Requires: binio-devel >= 1.4
31
32 %description devel
33 AdPlug is a free, multi-platform, hardware independent AdLib sound player
34 library, mainly written in C++. AdPlug plays sound data, originally created
35 for the AdLib (OPL2) audio board, on top of an OPL2 emulator or by using the
36 real hardware. No OPL2 chip is required for playback.
37
38 It supports various audio formats from MS-DOS AdLib trackers.
39
40 This package contains the C++ headers and documentation required for
41 building programs based on AdPlug.
42
43 %package static-devel
44 Group: Development/Libraries
45 Summary: Static library of AdPlug
46 Requires: %name-devel = %version-%release
47
48 %description static-devel
49 AdPlug is a free, multi-platform, hardware independent AdLib sound player
50 library, mainly written in C++. AdPlug plays sound data, originally created
51 for the AdLib (OPL2) audio board, on top of an OPL2 emulator or by using the
52 real hardware. No OPL2 chip is required for playback.
53
54 It supports various audio formats from MS-DOS AdLib trackers.
55
56 This package contains the static library required for statically
57 linking applications based on AdPlug.
58
59 %prep
60 %setup -q
61
62 %build
63 %configure
64 make 
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %makeinstall
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files
77 %defattr(-,root,root)
78 %doc README AUTHORS NEWS TODO
79 %_bindir/adplugdb
80 %_mandir/man1/adplugdb.1*
81 %_libdir/*.so.*
82
83 %files devel
84 %defattr(-,root,root)
85 %doc doc/*.txt doc/*.ps
86 %_includedir/adplug/*
87 %_libdir/*.so
88 %_libdir/*.la
89
90 %files static-devel
91 %defattr(-,root,root)
92 %_libdir/*.a
93
94 %changelog
95 * Tue Mar  4 2003 Götz Waschk <waschk@linux-mandrake.com> 1.4-1
96 - requires binio library
97 - fix groups for RH standard
98 - remove patches
99 - add adplugdb
100 - new version
101
102 * Tue Nov 26 2002 Götz Waschk <waschk@linux-mandrake.com> 1.3-1
103 - initial package