]> 4ch.mooo.com Git - 16.git/blob - 16/adplug/libbinio/binio_mdk.spec
renamed: 16/adplug/adplug-2.2.1/.DS_Store -> 16/adplug/adplug/.DS_Store
[16.git] / 16 / adplug / libbinio / binio_mdk.spec
1 %define name binio
2 %define version 1.4
3 %define release 1mdk
4 %define libname %mklibname %name 1
5
6 Summary: Binary I/O stream class library
7 Name: %{name}
8 Version: %{version}
9 Release: %{release}
10 Source0: %{name}-%{version}.tar.bz2
11 URL:http://libbinio.sourceforge.net
12 License: LGPL
13 Group: System/Libraries
14 BuildRoot: %{_tmppath}/%{name}-buildroot
15 Prefix: %{_prefix}
16
17 %description
18 The binary I/O stream class library presents a platform-independent
19 way to access binary data streams in C++.
20
21 The library is hardware independent in the form that it transparently
22 converts between the different forms of machine-internal binary data
23 representation.
24
25 It further employs no special I/O protocol and can be used on
26 arbitrary binary data sources.
27
28 %package -n %libname
29 Summary: Shared library for lib%name
30 Group: System/Libraries
31
32 %description -n %libname
33 The binary I/O stream class library presents a platform-independent
34 way to access binary data streams in C++.
35
36 The library is hardware independent in the form that it transparently
37 converts between the different forms of machine-internal binary data
38 representation.
39
40 It further employs no special I/O protocol and can be used on
41 arbitrary binary data sources.
42
43 This package contains the shared library needed to run applications
44 based on %name.
45
46 %package -n %libname-devel
47 Summary: Development files for lib%name
48 Group: Development/C++
49 Provides: %name-devel = %version-%release
50 Provides: lib%name-devel = %version-%release
51 Requires: %libname = %version-%release
52
53 %description -n %libname-devel
54 The binary I/O stream class library presents a platform-independent
55 way to access binary data streams in C++.
56
57 The library is hardware independent in the form that it transparently
58 converts between the different forms of machine-internal binary data
59 representation.
60
61 It further employs no special I/O protocol and can be used on
62 arbitrary binary data sources.
63
64 This package contains C++ header files, the shared library symlink and
65 the developer documentation for %name.
66
67 %package -n %libname-static-devel
68 Summary: Static library for lib%name
69 Group: Development/C++
70 Requires: %libname-devel = %version-%release
71
72 %description -n %libname-static-devel
73 The binary I/O stream class library presents a platform-independent
74 way to access binary data streams in C++.
75
76 The library is hardware independent in the form that it transparently
77 converts between the different forms of machine-internal binary data
78 representation.
79
80 It further employs no special I/O protocol and can be used on
81 arbitrary binary data sources.
82
83 This package contains the static library of %name.
84
85 %prep
86 %setup -q
87
88 %build
89 %configure2_5x
90 %make
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %makeinstall_std
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post -n %libname -p /sbin/ldconfig
100 %postun -n %libname -p /sbin/ldconfig
101
102 %post -n %libname-devel
103 %_install_info libbinio.info
104
105 %postun -n %libname-devel
106 %_remove_install_info libbinio.info
107
108 %files -n %libname
109 %defattr(-,root,root)
110 %doc README AUTHORS ChangeLog NEWS
111 %_libdir/*.so.*
112
113 %files -n %libname-devel
114 %defattr(-,root,root)
115 %_includedir/*.h
116 %_libdir/*.so
117 %_libdir/*.la
118 %_infodir/*.info*
119
120 %files -n %libname-static-devel
121 %defattr(-,root,root)
122 %_libdir/*.a
123
124
125 %changelog
126 * Mon Mar  3 2003 Götz Waschk <waschk@linux-mandrake.com> 1.2-1mdk
127 - initial package