]> 4ch.mooo.com Git - 16.git/blob - 16/adplug/libbinio-1.4/binio.spec
Please enter the commit message for your changes. Lines starting
[16.git] / 16 / adplug / libbinio-1.4 / binio.spec
1 %define name binio
2 %define version 1.4
3 %define release 1
4
5 Summary: Binary I/O stream class library
6 Name: %{name}
7 Version: %{version}
8 Release: %{release}
9 Source0: %{name}-%{version}.tar.bz2
10 URL:http://libbinio.sourceforge.net
11 License: LGPL
12 Group: System Environment/Libraries
13 BuildRoot: %{_tmppath}/%{name}-buildroot
14 Prefix: %{_prefix}
15
16 %description
17 The binary I/O stream class library presents a platform-independent
18 way to access binary data streams in C++.
19
20 The library is hardware independent in the form that it transparently
21 converts between the different forms of machine-internal binary data
22 representation.
23
24 It further employs no special I/O protocol and can be used on
25 arbitrary binary data sources.
26
27
28 %package devel
29 Summary: Development files for lib%name
30 Group: Development/Libraries
31 Requires: %name = %version-%release
32
33 %description devel
34 The binary I/O stream class library presents a platform-independent
35 way to access binary data streams in C++.
36
37 The library is hardware independent in the form that it transparently
38 converts between the different forms of machine-internal binary data
39 representation.
40
41 It further employs no special I/O protocol and can be used on
42 arbitrary binary data sources.
43
44 This package contains C++ header files, the shared library symlink and
45 the developer documentation for %name.
46
47 %prep
48 %setup -q
49
50 %build
51 %configure
52 make
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 %makeinstall
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post -p /sbin/ldconfig
62 %postun -p /sbin/ldconfig
63
64 %post devel
65 if [[ -f /usr/share/info/libbinio.info.gz ]];then /sbin/install-info /usr/share/info/libbinio.info.gz --dir=/usr/share/info/dir;fi
66
67 %postun devel
68 if [ "$1" = "0" ]; then if [[ -f /usr/share/info/libbinio.info.gz ]];then /sbin/install-info /usr/share/info/libbinio.info.gz --dir=/usr/share/info/dir --remove ;fi; fi
69
70 %files
71 %defattr(-,root,root)
72 %doc README AUTHORS ChangeLog NEWS
73 %_libdir/*.so.*
74
75 %files devel
76 %defattr(-,root,root)
77 %_includedir/*.h
78 %_libdir/*.so
79 %_libdir/*a
80 %_infodir/*.info*
81
82 %changelog
83 * Mon Mar  3 2003 Götz Waschk <waschk@linux-mandrake.com> 1.2-1
84 - initial package